June 19, 2019, 07:58:02 PM
collapse
collapse

Author Topic: Stage 3 LME install running rough.  (Read 235 times)

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Stage 3 LME install running rough.
« on: March 27, 2019, 03:41:16 PM »
Hey guys I installed a LME stage 3 kit on the sho, 2015 no PP

Plugs, thermostat, 3 bar, CAI, catch can and the ECO power sports intake tube into the throttle body.  everything but the exhaust, still on the workbench.

Went to fire it up today and its running off idle.  I have not installed the tune yet as I just wanted to move it,.  Is that the problem. I went over everything and cant see that I messed anything up, Iím a pretty decent wrench.  Regards, Dave

Offline 802SHO

  • Elite Member
  • : Essex Junction Vermont
  • Thank You
  • -Given: 1017
  • -Received: 426
  • Posts: 692
  • Boosted
Re: Stage 3 LME install running rough.
« Reply #1 on: March 27, 2019, 03:43:55 PM »
Did you swap the 3bar yet?  Just making sure bc it will run rough if you tuned it and started it without swapping out the 2 bar for the 3.  Disregard.  If you swapped them already and didn't tune it yet it will sputter for sure
« Last Edit: March 27, 2019, 03:45:31 PM by 802SHO »
2010 SHO non PP, GH upgraded turbos, GH upgraded IC, Alky Control Methonal Injection, Gen2 torque mounts, SP542 .028, 160 T, Airaid Intake, 3bar, Thunderstorm Catless Downpipes, custom stainless 2.5" double xpipe w/muffler deletes 4" quad tips, UPR Dual Valve Catch Can, 13+ PP Trans Cooler, Econoaid throttle Body Booster, Mickey Thompson 20x9 SC-5 Wheels, Continental Extreme Contact DW tires F: 245/40/20 R: 275/35/20, H&R Springs all around w/rear cut 1/2", Aeroforce Interceptor Gauge, Tuned by AJP Turbo

463awhp 569 awtq mustang dyno 6/13/19

11.833 @ 116.82 New England Dragway 10/14/18 AJP Turbo No DA Correction

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Stage 3 LME install running rough.
« Reply #2 on: March 27, 2019, 03:51:31 PM »
Yes I do have the 3 bar in there and no tune....it splitters and does not rev well.  Chugs and is running rough...idle is not bad but as soon as you give it gas it starts the above.

Offline 802SHO

  • Elite Member
  • : Essex Junction Vermont
  • Thank You
  • -Given: 1017
  • -Received: 426
  • Posts: 692
  • Boosted
Re: Stage 3 LME install running rough.
« Reply #3 on: March 27, 2019, 03:53:42 PM »
Put the 2bar back in and problem solved.  Or leave it in and tune it, when you start it it will idle great. 
2010 SHO non PP, GH upgraded turbos, GH upgraded IC, Alky Control Methonal Injection, Gen2 torque mounts, SP542 .028, 160 T, Airaid Intake, 3bar, Thunderstorm Catless Downpipes, custom stainless 2.5" double xpipe w/muffler deletes 4" quad tips, UPR Dual Valve Catch Can, 13+ PP Trans Cooler, Econoaid throttle Body Booster, Mickey Thompson 20x9 SC-5 Wheels, Continental Extreme Contact DW tires F: 245/40/20 R: 275/35/20, H&R Springs all around w/rear cut 1/2", Aeroforce Interceptor Gauge, Tuned by AJP Turbo

463awhp 569 awtq mustang dyno 6/13/19

11.833 @ 116.82 New England Dragway 10/14/18 AJP Turbo No DA Correction

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Stage 3 LME install running rough.
« Reply #4 on: March 27, 2019, 04:02:32 PM »
Thatís what I just did....swapped it and it runs perfect....man that stuff scares me that I fu@ked something up.....I really appreciate your knowledge and help.  Best regards, daVE

Offline 802SHO

  • Elite Member
  • : Essex Junction Vermont
  • Thank You
  • -Given: 1017
  • -Received: 426
  • Posts: 692
  • Boosted
Re: Stage 3 LME install running rough.
« Reply #5 on: March 27, 2019, 04:07:30 PM »
Thatís what I just did....swapped it and it runs perfect....man that stuff scares me that I fu@ked something up.....I really appreciate your knowledge and help.  Best regards, daVE

No worries you didn't hurt anything.  Glad I could help! 
2010 SHO non PP, GH upgraded turbos, GH upgraded IC, Alky Control Methonal Injection, Gen2 torque mounts, SP542 .028, 160 T, Airaid Intake, 3bar, Thunderstorm Catless Downpipes, custom stainless 2.5" double xpipe w/muffler deletes 4" quad tips, UPR Dual Valve Catch Can, 13+ PP Trans Cooler, Econoaid throttle Body Booster, Mickey Thompson 20x9 SC-5 Wheels, Continental Extreme Contact DW tires F: 245/40/20 R: 275/35/20, H&R Springs all around w/rear cut 1/2", Aeroforce Interceptor Gauge, Tuned by AJP Turbo

463awhp 569 awtq mustang dyno 6/13/19

11.833 @ 116.82 New England Dragway 10/14/18 AJP Turbo No DA Correction

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Stage 3 LME install running rough.
« Reply #6 on: March 27, 2019, 04:17:30 PM »
Fearing catastrophic motor damage i have already ordered a 1200 hp race motor for $16,000.  Ill throw this one in the front yard and chain the dogs to it.....off idle piece of crap junk motor.

Offline 802SHO

  • Elite Member
  • : Essex Junction Vermont
  • Thank You
  • -Given: 1017
  • -Received: 426
  • Posts: 692
  • Boosted
Re: Stage 3 LME install running rough.
« Reply #7 on: March 27, 2019, 04:29:11 PM »
Fearing catastrophic motor damage i have already ordered a 1200 hp race motor for $16,000.  Ill throw this one in the front yard and chain the dogs to it.....off idle piece of crap junk motor.

You'll have to open up the block and replace the piston rings you fried.  Just overnight all the parts
2010 SHO non PP, GH upgraded turbos, GH upgraded IC, Alky Control Methonal Injection, Gen2 torque mounts, SP542 .028, 160 T, Airaid Intake, 3bar, Thunderstorm Catless Downpipes, custom stainless 2.5" double xpipe w/muffler deletes 4" quad tips, UPR Dual Valve Catch Can, 13+ PP Trans Cooler, Econoaid throttle Body Booster, Mickey Thompson 20x9 SC-5 Wheels, Continental Extreme Contact DW tires F: 245/40/20 R: 275/35/20, H&R Springs all around w/rear cut 1/2", Aeroforce Interceptor Gauge, Tuned by AJP Turbo

463awhp 569 awtq mustang dyno 6/13/19

11.833 @ 116.82 New England Dragway 10/14/18 AJP Turbo No DA Correction

 

* Featured Topics

* Recent Topics

Re: What have you done to your Ecoboosted vehicle today?
by 5ohSHO | Today at 07:08:46 PM
Ah ok.  Yeah the flowers tend to be on the "softer" sid...
Re: 2010 Lincoln EBAP Photos
by Black Dream | Today at 06:35:32 PM
I test drove a 2011 Red version that had the exact same interior as yo...
Re: Glad to be here
by Black Dream | Today at 06:27:40 PM
Our poor dead G is being slowly parted out.  She was not my daily...
Re: Center caps on flowers
by 76fomoco | Today at 06:22:32 PM
you must have been without wheels at your location and or no batteries...
Re: Water in passenger floor
by Agentlongwood | Today at 05:48:48 PM
After all that, it didn't fix the leak lol.  It looks like m...
Re: battery terminal
by GhostlyGrenade | Today at 04:10:04 PM
Well I ordered a new battery as well as the updated rear trans mount. ...
Motircrafts SP-542 Spark plugs!
by ZSHO | Today at 03:14:45 PM
FYI- I noticed there is much interest in the SP-542 PLUGS and will be ...
2019 SHO Convention - Alternative Has Been Announced!
by SHOdded | Today at 02:53:36 PM
Since the official 2019 Convention is not happening, an alternative co...
Re: Gearhead SHO/Flex Intercooler Install Video
by Leadfoot | Today at 10:53:16 AM
I recalibrated my SHO, unfortunately with a MKS/Flex hybrid calibratio...
Re: Random thoughts for the day
by SHOdded | Today at 05:58:42 AM
Bulk shipping is expensive from the dealership.  But different de...
Re: Gearhead Intercooler Review
by avidmotion | June 18, 2019, 05:28:15 PM
....Me too....      :)...
Re: Power per mod discussion
by Black Dream | June 18, 2019, 03:31:45 PM
I could be wrong but I think he meant a Coors Light.........
Re: 2013 SHO Throttle Body Adjustment Screw Leaking?
by SHOdded | June 18, 2019, 08:57:10 AM
A nice little side project :D...
Re: R134a capacity
by Three Lions | June 18, 2019, 07:34:28 AM
Thanks guys. Most appreciated...
Re: Hotpipes, Meth Bungs and Nozzles
by shoNoff | June 18, 2019, 07:11:45 AM
I got lucky mine still had just enough sticking out so I could grab it...

Back to top