June 19, 2019, 08:26:08 PM
collapse
collapse

Author Topic: Dead 100% battery symptoms??  (Read 237 times)

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Dead 100% battery symptoms??
« on: March 24, 2019, 03:36:47 PM »
Been working on the SHO all winter but have been seeing battery issues and have had to charge it each time to start.  It was fine all last year up to the point i put it into storage for winter.  Today when i went to set up the tuner the car was dead....dead 100%.  Plugged in the battery charger and just heard clicking and lots of lights flashing.  Then i switched it to 6 volts and it just went faster.  Even plugged in the car is completely dead.  Any thoughts.  Its a 2015 but it has sat a lot from the first owner and me stored three winters since new and 6 months at the dealer.  Basically half its life thus far....parked.  Regards, Dave

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 11045
  • -Received: 3663
  • Posts: 15108
Re: Dead 100% battery symptoms??
« Reply #1 on: March 24, 2019, 03:50:01 PM »
Yeah, sitting kills batteries just as much as anything else.  4+ years is actually decent life.

I would replace it with a good AGM battery, such as an Odyssey 1500 (?) or a Motorcraft Toughmax 850.  AGM batteries will handle these tougher conditions better, take more deep discharges before quitting, etc.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

If tuned:  Take note of the strategy code as you return to stock (including 3 bar MAP to 2 bar MAP) -> take car in & get it serviced -> check strategy code when you get car back -> have tuner update your tune if the strategy code has changed -> reload tune -> ENJOY!

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Dead 100% battery symptoms??
« Reply #2 on: March 24, 2019, 03:55:45 PM »
Thatís what I was thinking.  I just did a search and a lot of folks swears by the Motorcraft BXT-65-850...Oíriley 159 in stock. 

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Dead 100% battery symptoms??
« Reply #3 on: March 24, 2019, 03:56:50 PM »
Dang...I remember when batteries were 29.99...and Iím only 50!

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 11045
  • -Received: 3663
  • Posts: 15108
Re: Dead 100% battery symptoms??
« Reply #4 on: March 24, 2019, 04:02:03 PM »
IKR?  yeah it is sticker shock ... bigtime.  If you buy the Ody, that is the best group 65 you can get.  But if you can't swing it, Toughmax is the next best.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

If tuned:  Take note of the strategy code as you return to stock (including 3 bar MAP to 2 bar MAP) -> take car in & get it serviced -> check strategy code when you get car back -> have tuner update your tune if the strategy code has changed -> reload tune -> ENJOY!

Offline HOONIN

  • Jr. Member
  • Thank You
  • -Given: 5
  • -Received: 4
  • Posts: 20
  • Ecobooster
Re: Dead 100% battery symptoms??
« Reply #5 on: March 24, 2019, 04:11:33 PM »
Ok...Money no object!!!!!  HHEHEHE.  Has anyone else seen these same symptoms with a dead battery...???  IT wont charge, when plugged into the battery charger it just clicks under the hood, lights blink, collision light blinking....nothing else works....cars dead as a doorknob.  I guess I can also have them test it.  Regards, Dave
« Last Edit: March 24, 2019, 04:36:15 PM by HOONIN »

Offline Gjkrisa

  • Elite Member
  • : Fairbanks, AK
  • Thank You
  • -Given: 901
  • -Received: 184
  • Posts: 790
  • Ecobooster
    • Photos
Re: Dead 100% battery symptoms??
« Reply #6 on: March 24, 2019, 09:06:18 PM »
Ok...Money no object!!!!!  HHEHEHE.  Has anyone else seen these same symptoms with a dead battery...???  IT wont charge, when plugged into the battery charger it just clicks under the hood, lights blink, collision light blinking....nothing else works....cars dead as a doorknob.  I guess I can also have them test it.  Regards, Dave
What kind of battery charger do you have?
The ctek and optima battery charger usually won't start a charge unless you get one of those dumb Sears or die hard chargers that have the metal case then once it's up to 9 volts the smart chargers will work again.


Sent from my Pixel 2 XL using Tapatalk

2016 Taurus SHO pp Shadow Black
diy emblems,jms boost max, FORscan modder

Offline 802SHO

  • Elite Member
  • : Essex Junction Vermont
  • Thank You
  • -Given: 1017
  • -Received: 426
  • Posts: 692
  • Boosted
Re: Dead 100% battery symptoms??
« Reply #7 on: March 25, 2019, 02:42:22 AM »
Ok...Money no object!!!!!  HHEHEHE.  Has anyone else seen these same symptoms with a dead battery...???  IT wont charge, when plugged into the battery charger it just clicks under the hood, lights blink, collision light blinking....nothing else works....cars dead as a doorknob.  I guess I can also have them test it.  Regards, Dave

Money no object!  🤔😂 Not too often we can say that when replacing something eh?  Lol! 
2010 SHO non PP, GH upgraded turbos, GH upgraded IC, Alky Control Methonal Injection, Gen2 torque mounts, SP542 .028, 160 T, Airaid Intake, 3bar, Thunderstorm Catless Downpipes, custom stainless 2.5" double xpipe w/muffler deletes 4" quad tips, UPR Dual Valve Catch Can, 13+ PP Trans Cooler, Econoaid throttle Body Booster, Mickey Thompson 20x9 SC-5 Wheels, Continental Extreme Contact DW tires F: 245/40/20 R: 275/35/20, H&R Springs all around w/rear cut 1/2", Aeroforce Interceptor Gauge, Tuned by AJP Turbo

463awhp 569 awtq mustang dyno 6/13/19

11.833 @ 116.82 New England Dragway 10/14/18 AJP Turbo No DA Correction

Offline lamrith

  • Elite Member
  • : PNW
  • Thank You
  • -Given: 106
  • -Received: 359
  • Posts: 783
  • Ecobooster
Re: Dead 100% battery symptoms??
« Reply #8 on: March 25, 2019, 10:47:12 AM »
Thatís what I was thinking.  I just did a search and a lot of folks swears by the Motorcraft BXT-65-850...Oíriley 159 in stock.
Make sure to check your Ford Dealer.  Mine has that battery for $139.99 and in stock.
'13 Sho PP, SCT x4, AJP 92-Octane rev6 (14psi&20spark) NGK 6510, 3Bar, K&N CAI, PPE Catted DP, Dynomax Axleback, H&R's, 20*9.5 Voxx Lago.

 

* Featured Topics

* Recent Topics

Re: What have you done to your Ecoboosted vehicle today?
by 5ohSHO | Today at 07:08:46 PM
Ah ok.  Yeah the flowers tend to be on the "softer" sid...
Re: 2010 Lincoln EBAP Photos
by Black Dream | Today at 06:35:32 PM
I test drove a 2011 Red version that had the exact same interior as yo...
Re: Glad to be here
by Black Dream | Today at 06:27:40 PM
Our poor dead G is being slowly parted out.  She was not my daily...
Re: Center caps on flowers
by 76fomoco | Today at 06:22:32 PM
you must have been without wheels at your location and or no batteries...
Re: Water in passenger floor
by Agentlongwood | Today at 05:48:48 PM
After all that, it didn't fix the leak lol.  It looks like m...
Re: battery terminal
by GhostlyGrenade | Today at 04:10:04 PM
Well I ordered a new battery as well as the updated rear trans mount. ...
Motircrafts SP-542 Spark plugs!
by ZSHO | Today at 03:14:45 PM
FYI- I noticed there is much interest in the SP-542 PLUGS and will be ...
2019 SHO Convention - Alternative Has Been Announced!
by SHOdded | Today at 02:53:36 PM
Since the official 2019 Convention is not happening, an alternative co...
Re: Gearhead SHO/Flex Intercooler Install Video
by Leadfoot | Today at 10:53:16 AM
I recalibrated my SHO, unfortunately with a MKS/Flex hybrid calibratio...
Re: Random thoughts for the day
by SHOdded | Today at 05:58:42 AM
Bulk shipping is expensive from the dealership.  But different de...
Re: Gearhead Intercooler Review
by avidmotion | June 18, 2019, 05:28:15 PM
....Me too....      :)...
Re: Power per mod discussion
by Black Dream | June 18, 2019, 03:31:45 PM
I could be wrong but I think he meant a Coors Light.........
Re: 2013 SHO Throttle Body Adjustment Screw Leaking?
by SHOdded | June 18, 2019, 08:57:10 AM
A nice little side project :D...
Re: R134a capacity
by Three Lions | June 18, 2019, 07:34:28 AM
Thanks guys. Most appreciated...
Re: Hotpipes, Meth Bungs and Nozzles
by shoNoff | June 18, 2019, 07:11:45 AM
I got lucky mine still had just enough sticking out so I could grab it...

Back to top