July 04, 2020, 11:32:24 AM
collapse
collapse

Author Topic: "How-To" SHO and Flex convert to vent to atmosphere with factory blow off valves  (Read 742163 times)

Offline MiWiAu

  • Elite Member
  • *
  • Milwaukee
  • Thank You
  • -Given: 297
  • -Received: 400
  • Posts: 855
  • EcoBoobster
Really at a loss what could be causing it to vent only under light load. I have thought for the longest time it was just a symptom of an automatic car but it seems more and more like I might have hurt the BOV(s) when I fudged the capping of all four nipples...

My XSport does this occasionally as well. It's particularly noticeable when using cruise control up a light grade. It seems that the BOV noise coincides with the controller reducing throttle, which makes sense. If I wasn't VTA, I probably wouldn't ever notice it (no noise).

I put the breather filters on my BOVs and that muted the sound some for the light load blow off events, and made it substantially less annoying.

I'm not convinced that what you're experiencing is anything other than "normal." :)



Sent from my iPhone using Tapatalk
2013 XSport

Offline ZSHO

  • Forum Supporter
  • RotM Winner
  • Elite Member
  • *
  • New York SHO
  • Thank You
  • -Given: 1935
  • -Received: 4069
  • Posts: 1973
  • Trap Speed of almost 116 mph.
@- Mase would check the front/rear BOV to see if the Diaphragm is not torn and causing your issues. 2-8mm socket.
I would love to see some pics of the engine. Z

« Last Edit: June 17, 2017, 10:57:35 PM by ZSHO »


2013 Performance Package SHO| Livernois Custom Methanol Tune|3-Bar Map|Reische-170-Stat|Full Race Tial-10psi BOV in Black|PPE-Gloss Black Hot Pipes|EPP Dual Intake in Gloss Black|PPE Catted DP|Corsa Sport Cat Back Exhaust|H&R Sport-Springs|CFM Performance Billet Valve Cover Breather In Gloss Black|Llumar 20%Ceramic window Tint|MSD Ignition Coils in Black|Extreme Roof Spoiler|Redline Fluids all around|Gearhead Intercooler|First-SHO With Direct Port Alky-VP-M1-100%-Methanol Injection|LMS-Custom-Dyno-Tuned @ 415whp-465wtq| Best Trap Speed of 115.54 mph|

Offline mprivi

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 3
  • Ecobooster
As another alternative to those interested, I only disconnected from the BOV side and left the intake side of the tubes attached.  I then found the appropriate size "plug", which turned out to be a 1/2" PVC Cap.  I pushed the caps into the tubs and pulled the clamp back up over the caps.  Seems to be working well so far, and should be easier to reattached to stock if I want to for warranty work.
Do you have a pic? Interested in this


Sent from my iPhone using Tapatalk
2011 Ford Flex Titanium TBM

Offline JDW1

  • Full Member
  • *
  • Birmingham, Al
  • Thank You
  • -Given: 30
  • -Received: 6
  • Posts: 119
So I found these on Amazon that looks like a solution

https://www.amazon.com/10-Pack-Rubber-Plastic-Tubing/dp/B0742KBV6M/ref=sr_1_16?ie=UTF8&qid=1505144032&sr=8-16&keywords=1%22+cap

I am curious as to why you couldnt just set up the recirc again if the locations of the BPV's are the same? 

13 SHO, Unleashed 3bar Tune, 1 step cooler NGK's, MDesign CAI, 170 t-stat and meth.

 

* Recent Topics

Re: New Moderator
by ZSHO | Today at 08:05:01 AM
Congrats E!  I have not been active much but Great to see others ...
Re: New member Omaha, Nebraska
by FearlessAZ | Today at 04:50:17 AM
Welcome to the forum!Love that color. Was that a factory color or some...
Re: Finally bought an XDI35 HPFP
by bamsho | July 03, 2020, 10:42:00 PM
Here is a comparison slips.  There is an 20 degree ambient temp d...
Re: Ride of The Month - July 2020!!
by Dannymack | July 03, 2020, 06:29:59 PM
Going for round #2.2013 MKSAJP E30Godspeed SpringsBunch of Aesthetic M...
Forum Stickers
by StealBlueSho | July 02, 2020, 01:47:07 PM
EBPF Family..Anyone have any recommendations on who to go through for ...
Re: B1086- Air Distribution Damper Motor - Panel/floor/defrost not working
by Gjkrisa | July 02, 2020, 01:19:45 PM
New panel worked think I cracked part of the new facia trying to take ...
Re: DannyMack 13 MKS "Old Man" Build and Maintenance Thread
by Dannymack | July 02, 2020, 01:17:24 PM
Quick update. Been enjoying the car in its current form for a couple m...
Re: Help! Removal of Rear Turbo
by 802SHO | July 02, 2020, 12:18:51 PM
Thanks to you guys for all the tips. I wasn't sure about the knuc...
Re: 2015 Ford Explorer Sport - AC Compressor Not Starting
by lotusnotes | July 02, 2020, 12:07:40 PM
So I figured this out - whoever mounted the light bar on this truck be...
Re: TASCA=Fail....
by nickstewartroc | July 02, 2020, 12:01:03 PM
I usually use tasca to look up part numbers.  And then go to my l...

Back to top
SimplePortal 2.3.5 © 2008-2012, SimplePortal