July 07, 2020, 11:59:54 PM
collapse
collapse

Author Topic: 2010 Taurus SHO Shudder at low RPM/high load  (Read 234 times)

Offline general_annoyance

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 5
  • Ecobooster
2010 Taurus SHO Shudder at low RPM/high load
« on: June 22, 2020, 09:27:05 PM »
Hey all, I feel like this topic has been beaten to death, but I figured I'd post another thread to make sure I'm not needlessly spending money. I have a 2010 SHO with around 98k on the clock (owned since ~60k). Recently I've noticed a problem where it'll sometimes shudder and fluctuate RPMs under certain circumstances, mainly when trying to accelerate on the highway. Before it downshifts, it'll shudder real bad and the RPMs will bounce around a little. It feels a lot like a misfire from another car that had coilpack issues, but there's no CEL.

It seemed to go away for the most part, but then I got the power pack from Torrie at Unleashed. I applied the tune, spark plugs, and thermostat and the problem has come back worse than ever.

Today I drained about an ounce of oil-ly goop from the intercooler, but that didn't seem to help anything. I've monitored torque converter desired slip vs actual slip with Forscan, but there doesn't seem to be any deviation that correlates with the shudder. At this point, I'm leaning towards the PTU. I haven't had a chance to have someone check the TSB out on it yet.

Like I said, I'm thinking it's the PTU but I thought I'd get some second opinions before I start spending money needlessly.

Offline Macgyver

  • Super Moderator
  • Elite Member
  • *
  • Reading, Pa.......
  • Thank You
  • -Given: 95
  • -Received: 323
  • Posts: 734
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #1 on: June 22, 2020, 10:49:02 PM »
Purely a guess but what are your Boost pressures like ? It might be a BOV/Wastegate issue.

Offline general_annoyance

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 5
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #2 on: June 23, 2020, 07:19:59 AM »
I haven't logged it but it seems to hold fine. I saw some other post about bad gaskets, I'll check those anyway.

Offline general_annoyance

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 5
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #3 on: June 24, 2020, 12:09:10 PM »
BOV gaskets were fine. I pulled and check all six spark plugs; two of them the ceramic disintegrated as soon as I took it out of the socket. Replaced those two, checked gap on the rest and reinstalled. I was unable to replicate the problem on a test drive, all seemed fine. Hopefully it stays that way.

Offline Macgyver

  • Super Moderator
  • Elite Member
  • *
  • Reading, Pa.......
  • Thank You
  • -Given: 95
  • -Received: 323
  • Posts: 734
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #4 on: June 25, 2020, 09:28:54 PM »
That is good news sort of.

What plugs were in there ?

Offline general_annoyance

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 5
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #5 on: June 26, 2020, 08:53:52 AM »
They were all NGK LTR7IX-11 6510.

Offline TopherSho

  • Elite Member
  • *
  • Eugene Oregon
  • Thank You
  • -Given: 483
  • -Received: 367
  • Posts: 1535
  • 1st boosted rig!
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #6 on: June 26, 2020, 11:37:16 AM »
hmmpf.  Not to bag on NGK But I also had two different sets of NGKs fail i less than 20k miles.  Went back (then) to the 542's and only had fouling issues from then on (to cold a plug for my 2010 non-pp)
2010 non-pp, 50k miles, 3-bar,  .30 plugs, 170-T-stat, SNOW-KIT STG1, AJP TURBO METH TUNE-REV3
 
Best of 12.61 no DA correction

Offline Macgyver

  • Super Moderator
  • Elite Member
  • *
  • Reading, Pa.......
  • Thank You
  • -Given: 95
  • -Received: 323
  • Posts: 734
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #7 on: June 26, 2020, 04:01:38 PM »
hmmpf.  Not to bag on NGK But I also had two different sets of NGKs fail i less than 20k miles.  Went back (then) to the 542's and only had fouling issues from then on (to cold a plug for my 2010 non-pp)

I agree as AJP said keep the OEMs in on regular tuned cars without extreme mods.

Offline general_annoyance

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 0
  • Posts: 5
  • Ecobooster
Re: 2010 Taurus SHO Shudder at low RPM/high load
« Reply #8 on: June 30, 2020, 07:50:45 AM »
I'll keep that in mind. I've put another ~200mi or so on them without any issues. I'll check them again in a bit and see how they're doing.

 

* Recent Topics

Re: Ride of The Month - July 2020!!
by bpd1151 | Today at 10:46:47 PM
That doggone BPD guy shattered my build tho lol.Sorry......Sent from ...
Re: What have you done to your Ecoboosted vehicle today?
by 802SHO | Today at 09:29:20 PM
I have never seen 32mpg.. good for you!I see like 14 mpg lol!  Bu...
Re: SM105K's Ownership/Performance/Maintenance Thread
by sm105k | Today at 11:44:31 AM
On my return trip I averaged 88 mph through CA and 95 mph through AZ. ...
Re: Has anyone install custom Hood?
by sm105k | Today at 11:07:33 AM
Ford Derrick is the owner, I pinged him back in May of last year.. att...
Re: Phenolic Spacers
by 802SHO | Today at 09:43:41 AM
Nevermind, purchased some from my local O'Reillys for $54Sent fro...
Re: AO tune vs downpipes
by StealBlueSho | Today at 09:37:30 AM
Matt R. said I didn't need a revision for my catted PPE's on...
Re: SHOdded Officially Retiring as Admin
by 802SHO | Today at 05:13:28 AM
Manu you've been such a big help in so many aspects of everything...
Re: TASCA=Fail....
by SilvererSHO | July 06, 2020, 09:41:25 PM
And to confuse things even more, here's the listing for a 2013 SH...
Re: Edge ST .......Here she is
by Macgyver | July 06, 2020, 07:19:10 PM
I really like it.  How is the room?  Maybe one of those will...
Re: New SHO owner with problems
by My15SHO | July 06, 2020, 04:10:09 PM
Good luck but I don't like the sound of them being so quick to ju...

Back to top
SimplePortal 2.3.5 © 2008-2012, SimplePortal