August 05, 2021, 11:31:26 AM
collapse

Recent Posts

Pages: [1] 2 3 ... 10
1
Moogs were the only option for me as the OEM's were backordered to hell and back. I didn't want to take the OEM originals to a shop to get pressed.
I guess the only good thing is the moogs were cheap on Autozone through a commercial account and have a lifetime warranty.
The car was just dropped off at Alignment Shop Inc in Ormond Beach to be remeasured by hand, Took it to two local honest mechanics that said nothing is loose.

2
General Discussion / Re: Any advice on how to improve 1/4 mile times?
« Last post by Blackhawk on August 04, 2021, 11:46:49 PM »
This car should be running at least high 11s with all those mods.  Any luck working with your tuners ?
3
Good notes to keep under the hat,  thanks for the share and update!
4
Troubleshooting / 2010 Taurus SHO, PCM issues
« Last post by withku on August 03, 2021, 01:41:48 PM »
Hey all, my 2010 has been acting up lately. A while ago, my a/c stopped working intermittently, air just got hot and humid. I reset my APIM , and that solved it for a couple weeks. Itís back to working about half the time. I checked codes though ForScan, and my PCM isnít receiving the required voltage, and multiple other modules lost communication with the PCM, including my APIM. I checked my battery and alternator, both are good. Bad PCM? What are your thoughts?

2010 Taurus SHO w/ stage 4 LMS T460


Sent from my iPhone using Tapatalk
5
Good video. You think you may lose some fluid through the vent if it heats up?

Sent from my SM-A705W using Tapatalk

6
Vehicle Builds / ecoboost_xsport Consolidated Build/Maintenance Thread
« Last post by Ecoboost_xsport on July 30, 2021, 08:24:58 PM »
Even though I haven't been posting as frequently lately (YouTube content or other social media), I've still been plugging away at this project.  Trying to eat this elephant one bite at a time.  Here's a bit of an update on where I stand with all my many projects pertaining to the Explorer build...

https://www.fortheworkshop.com/?p=3422
7
on the 2.7, ford says to replace the ECT sensor and/or the knock sensor harness. how do the knock readings look in your datalog.
https://drive.google.com/file/d/1CDkqgarqkxrW8v6YemuiS2lyzgr-M363/view?usp=sharing
8
How To Articles / Boost / Vacuum Source
« Last post by Ecoboost_xsport on July 29, 2021, 12:36:21 PM »
Those of you wondering where a decent place to tap into a boost/vacuum source, here's one way to skin that cat.
 
 Wanted to keep this particular write-up out of my build thread as it can pertain to a few different platforms and is more informational than anything specific about my build.
https://www.fortheworkshop.com/?p=3418
9
New Member Introductions / Re: New from Minnesota...
« Last post by PDSHO on July 27, 2021, 04:15:43 PM »
Greetings from Nebraska.


Greg
10
New Member Introductions / Re: Ol' Guy in New England........
« Last post by PDSHO on July 27, 2021, 04:13:04 PM »
Greetings from Nebraska.


Greg
Pages: [1] 2 3 ... 10

SimplePortal 2.3.5 © 2008-2012, SimplePortal