June 19, 2019, 07:58:49 PM
collapse
collapse

Author Topic: Surging - Bad fuel injector?  (Read 1224 times)

Offline Blackhawk

  • Full Member
  • : Chicago Suburbs
  • Thank You
  • -Given: 19
  • -Received: 53
  • Posts: 245
  • Ecobooster
Re: Surging - Bad fuel injector?
« Reply #15 on: February 27, 2019, 09:40:44 AM »
Put forscan  on it the last couple days, there are misfires incrementing overtime as I drive it but don't seem to increase while the shuddering is happening.  Like 9 total for a 45 minutes drive.  The other thing I noticing it while going 35-55 or so I seem the actual converter slippage toggling between 1 and 100 or so while I am feeling the shuddering.   The desired converter slippage is like 20 or below while it is doing this.

At highway speeds the desired and actual convertor slippage is 0 or 1.

I guess I will put new stock gapped plugs in and see whats happens. 

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 11045
  • -Received: 3663
  • Posts: 15108
Re: Surging - Bad fuel injector?
« Reply #16 on: February 27, 2019, 02:02:55 PM »
Best of luck, fingers crossed :)
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

If tuned:  Take note of the strategy code as you return to stock (including 3 bar MAP to 2 bar MAP) -> take car in & get it serviced -> check strategy code when you get car back -> have tuner update your tune if the strategy code has changed -> reload tune -> ENJOY!

Offline SHO9987

  • Full Member
  • : Omaha
  • Thank You
  • -Given: 6
  • -Received: 31
  • Posts: 54
  • Ecoboost
Re: Surging - Bad fuel injector?
« Reply #17 on: March 26, 2019, 03:59:26 PM »
Any update how it is driving ?  I am getting the shuddering as well and was ready to bring it to the dealer for warranty.  Now I am thinking about putting the stock plugs back in before I bring it in.  Not sure if they would give me crap about having tightly gapped colder plugs.

I actually do have an update.  90% of the problem was my throttle body.  One possibility was that I likely messed with the positioning screw on the top of it sometime in the past (I don't really remember).  Another possibility was the water/meth, I have sprayed w/m daily for the last 40k miles on this car and have heard that it can sometimes get into the TB housing.  Regardless, I replaced with a new TB and saw a significant improvement in symptoms. 

The surging although much better, was still there.  AJP made quite a few adjustments to the tune, I'm sure he can chime in with all that was adjusted.  I think he allowed a little more slip in the torque converter and adjusted shift points to keep the car out of the troubled surging areas.  After that the car has been running great ever since. 

Even though the transmission fluid is clear/pink and it was blessed off by the transmission shop... I still think it is just a matter of time until the torque converter goes.  The car has almost 100k miles, the last 40k being pretty hard miles.
2013 SHO Non-PP, Megan Racing Coilovers, Catless DPs, Custom 2.5" exhaust, Airraid CAI, AJP Boost Regulator, Stock Turbo Upgrades, 7psi WGAs, snow - W/M system, AJP tuned

Offline Blackhawk

  • Full Member
  • : Chicago Suburbs
  • Thank You
  • -Given: 19
  • -Received: 53
  • Posts: 245
  • Ecobooster
Re: Surging - Bad fuel injector?
« Reply #18 on: May 06, 2019, 01:50:50 PM »
A quick update for me. put the stock plugs in but still had the shuddering and misfires slowly incrementing.   Brought it to the dealer and they spent 3 weeks chasing the misfire counter by replacing plugs/3 new coils and finally escalated to corporate.  Corp had them run some extra tests and they determined it was the torque converter (which I had suggested when I dropped off).  The shudder went away once it was replaced.  Driving the new loaner vehicles gave me the new car bug and I traded my 2011 SHO in on a 2017 MKZ 3.0t AWD on Saturday.  Loving it so far, just need to spend some time researching what I want to mod :)

Stopped at the drag strip 45 mins after leaving the dealer, only got one pass in, 13.7@102.  I'm guessing a full tank of 87 octane and 41 PSI in the tires didn't help.  Hoping for low 13's stock with some good 93 and playing with tire  pressure.
« Last Edit: May 06, 2019, 01:52:56 PM by Blackhawk »

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 11045
  • -Received: 3663
  • Posts: 15108
Re: Surging - Bad fuel injector?
« Reply #19 on: May 06, 2019, 02:21:20 PM »
Torque converter shudder gone, time slip shudder ...

Glad the dealer and Ford were able to resolve, enjoy!
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

If tuned:  Take note of the strategy code as you return to stock (including 3 bar MAP to 2 bar MAP) -> take car in & get it serviced -> check strategy code when you get car back -> have tuner update your tune if the strategy code has changed -> reload tune -> ENJOY!

Offline MeanKS

  • Sr. Member
  • Thank You
  • -Given: 36
  • -Received: 48
  • Posts: 304
  • Ecobooster
Re: Surging - Bad fuel injector?
« Reply #20 on: May 06, 2019, 10:21:14 PM »
A quick update for me. put the stock plugs in but still had the shuddering and misfires slowly incrementing.   Brought it to the dealer and they spent 3 weeks chasing the misfire counter by replacing plugs/3 new coils and finally escalated to corporate.  Corp had them run some extra tests and they determined it was the torque converter (which I had suggested when I dropped off).  The shudder went away once it was replaced.  Driving the new loaner vehicles gave me the new car bug and I traded my 2011 SHO in on a 2017 MKZ 3.0t AWD on Saturday.  Loving it so far, just need to spend some time researching what I want to mod :)

Stopped at the drag strip 45 mins after leaving the dealer, only got one pass in, 13.7@102.  I'm guessing a full tank of 87 octane and 41 PSI in the tires didn't help.  Hoping for low 13's stock with some good 93 and playing with tire  pressure.

Nice!

wish Ford had put at least an 8spd transmission in the MKZ and Conti by 2017.
MKS-EB...

Offline Blackhawk

  • Full Member
  • : Chicago Suburbs
  • Thank You
  • -Given: 19
  • -Received: 53
  • Posts: 245
  • Ecobooster
Re: Surging - Bad fuel injector?
« Reply #21 on: May 07, 2019, 07:04:55 AM »
They stuck one in the new Edge ST, disappointed as well that they didn't throw it in on the 3.0 Lincolns.  It was definitely one of the negatives when evaluating my decisions.

A quick update for me. put the stock plugs in but still had the shuddering and misfires slowly incrementing.   Brought it to the dealer and they spent 3 weeks chasing the misfire counter by replacing plugs/3 new coils and finally escalated to corporate.  Corp had them run some extra tests and they determined it was the torque converter (which I had suggested when I dropped off).  The shudder went away once it was replaced.  Driving the new loaner vehicles gave me the new car bug and I traded my 2011 SHO in on a 2017 MKZ 3.0t AWD on Saturday.  Loving it so far, just need to spend some time researching what I want to mod :)

Stopped at the drag strip 45 mins after leaving the dealer, only got one pass in, 13.7@102.  I'm guessing a full tank of 87 octane and 41 PSI in the tires didn't help.  Hoping for low 13's stock with some good 93 and playing with tire  pressure.

Nice!

wish Ford had put at least an 8spd transmission in the MKZ and Conti by 2017.

 

* Featured Topics

* Recent Topics

Re: What have you done to your Ecoboosted vehicle today?
by 5ohSHO | Today at 07:08:46 PM
Ah ok.  Yeah the flowers tend to be on the "softer" sid...
Re: 2010 Lincoln EBAP Photos
by Black Dream | Today at 06:35:32 PM
I test drove a 2011 Red version that had the exact same interior as yo...
Re: Glad to be here
by Black Dream | Today at 06:27:40 PM
Our poor dead G is being slowly parted out.  She was not my daily...
Re: Center caps on flowers
by 76fomoco | Today at 06:22:32 PM
you must have been without wheels at your location and or no batteries...
Re: Water in passenger floor
by Agentlongwood | Today at 05:48:48 PM
After all that, it didn't fix the leak lol.  It looks like m...
Re: battery terminal
by GhostlyGrenade | Today at 04:10:04 PM
Well I ordered a new battery as well as the updated rear trans mount. ...
Motircrafts SP-542 Spark plugs!
by ZSHO | Today at 03:14:45 PM
FYI- I noticed there is much interest in the SP-542 PLUGS and will be ...
2019 SHO Convention - Alternative Has Been Announced!
by SHOdded | Today at 02:53:36 PM
Since the official 2019 Convention is not happening, an alternative co...
Re: Gearhead SHO/Flex Intercooler Install Video
by Leadfoot | Today at 10:53:16 AM
I recalibrated my SHO, unfortunately with a MKS/Flex hybrid calibratio...
Re: Random thoughts for the day
by SHOdded | Today at 05:58:42 AM
Bulk shipping is expensive from the dealership.  But different de...
Re: Gearhead Intercooler Review
by avidmotion | June 18, 2019, 05:28:15 PM
....Me too....      :)...
Re: Power per mod discussion
by Black Dream | June 18, 2019, 03:31:45 PM
I could be wrong but I think he meant a Coors Light.........
Re: 2013 SHO Throttle Body Adjustment Screw Leaking?
by SHOdded | June 18, 2019, 08:57:10 AM
A nice little side project :D...
Re: R134a capacity
by Three Lions | June 18, 2019, 07:34:28 AM
Thanks guys. Most appreciated...
Re: Hotpipes, Meth Bungs and Nozzles
by shoNoff | June 18, 2019, 07:11:45 AM
I got lucky mine still had just enough sticking out so I could grab it...

Back to top