May 22, 2019, 10:11:05 AM
collapse
collapse

Author Topic: PTU blew.. (confirmed PTU now)  (Read 6343 times)

Offline sub_ETCS_ret

  • Full Member
  • Thank You
  • -Given: 25
  • -Received: 4
  • Posts: 54
  • Ecobooster
Re: PTU blew.. (confirmed PTU now)
« Reply #135 on: December 04, 2018, 04:56:32 PM »
Did you have any sounds before it blew? I'm trying to determine where my noise is coming from. I think I saw that @ajpturbo said that it's chain driven. It very much sounds like it could he a chain slapping. It mostly does it when it's cold, making a left turn under acceleration.

Sent from my SM-G950U using Tapatalk
« Last Edit: December 04, 2018, 05:00:10 PM by sub_ETCS_ret »
15 SHO NonPP. 3bar map, OEM plugs gapped 0.030, AJPTurbo tuned.

Offline TopherSho

  • Elite Member
  • : Eugene Oregon
  • Thank You
  • -Given: 445
  • -Received: 269
  • Posts: 1322
  • 1st boosted rig!
Re: PTU blew.. (confirmed PTU now)
« Reply #136 on: December 04, 2018, 05:58:30 PM »
Not a PEEP ... I pulled out of the car wash,  was not even past 20% throttle, slap! followed by Bang! bang! bang! and that AWFUL smell ...  I just read your post,  i also think shaft.  We have had two other members loose their shafts on 13's+
2010 non-pp, 50k miles, 3-bar,  .30 plugs, 170-T-stat, SNOW-KIT STG1, AJP TURBO METH TUNE-REV3
 
Best of 12.61 no DA correction

Offline sub_ETCS_ret

  • Full Member
  • Thank You
  • -Given: 25
  • -Received: 4
  • Posts: 54
  • Ecobooster
Re: PTU blew.. (confirmed PTU now)
« Reply #137 on: December 04, 2018, 06:18:08 PM »
Not a PEEP ... I pulled out of the car wash,  was not even past 20% throttle, slap! followed by Bang! bang! bang! and that AWFUL smell ...  I just read your post,  i also think shaft.  We have had two other members loose their shafts on 13's+
Thanks for the info and your opinion as well.

Sent from my SM-G950U using Tapatalk

15 SHO NonPP. 3bar map, OEM plugs gapped 0.030, AJPTurbo tuned.

 

* Featured Topics

* Recent Topics

Re: Torque PIDs...Take 2
by sm105k | Today at 09:22:28 AM
Jman,adjust your minimum value to -7.0adjust your maximum value to 7.0...
Re: 2013 Focus st (250) engine noise
by sm105k | Today at 09:18:18 AM
Have you checked your rear engine mount? Thanks for the reply, Iím fai...
Re: LEBANON VALLEY DRAG WAY 5/25/19
by mybigsho | Today at 08:46:31 AM
Cool!! Weather is looking ok.. I'll be hanging with the factory a...
Re: First SHO With Direct Port Methanol injection!!
by ZSHO | Today at 08:37:56 AM
Bit of a Pita so far but @ least the weather is complying! Z http://i...
Re: 802SHO 2010 Build
by sm105k | Today at 06:15:02 AM
Good stuff, keep rolling....
Re: What have you done to your Ecoboosted vehicle today?
by ZSHO | May 21, 2019, 06:33:35 PM
When push comes to shove! :D  BTW - In conjunction with spark plu...
Re: For those of you running catless on a stock catback
by 802SHO | May 21, 2019, 03:26:02 PM
Only video I have of my exhaust when it was catless downpipes to stock...
Re: A sad, sad day in the history of my SHO.....
by FLEXXX | May 21, 2019, 07:14:06 AM
That sucks, been there, not fun. ....
Re: StopTech Rotors with Akebono Pads
by DirtClodimus | May 20, 2019, 07:56:30 PM
Calipers and front pad pics added to the album. Couple nicks in the po...
Re: Project SC (1972 Celica race car with a 2.3 ecoboost.)
by Macgyver | May 20, 2019, 07:45:01 PM
That is gonna be a fun car....
Re: Had a tiny exhaust leak....
by ZSHO | May 20, 2019, 06:54:55 PM
Hmm! Here are mine! Zhttps://i.imgur.com/6UwBEPzh.jpg...
Re: New Member - 14 SHO Non-PP
by DirtClodimus | May 20, 2019, 06:10:19 PM
more so interested in in your 1/4 mile timesUnfortunately, Iíve never ...
Re: F150 Platinum FX4
by sholxgt | May 20, 2019, 04:51:02 PM
And I'm now ready for it's 1,000 mile party!  Just 150 ...
Re: Random thoughts for the day
by SHOdded | May 20, 2019, 02:24:07 PM
Yeah, inevitable unfortunately.  With the shakeup of the way Ford...
MOVED: Had a tiny exhaust leak....
by ZSHO | May 20, 2019, 01:30:11 PM
This topic has been moved to Intake/Exhaust.https://www.ecoboostperfor...

Back to top