September 27, 2022, 04:01:41 PM
collapse
collapse

Author Topic:  2014 SHO Surging / Loss of Power  (Read 2784 times)

Offline Night Hawk

  • Sr. Member
  • *
  • New England
  • Thank You
  • -Given: 96
  • -Received: 71
  • Posts: 310
  • Ecobooster
  • Liked:
  • Likes Given: 5
Re: 2014 SHO Surging / Loss of Power
« Reply #15 on: July 30, 2022, 10:52:11 AM »


Id check all the vacc lines, especially involving boost.  It happened to me at the track one year no codes, no other symptoms just waaay down on trap speed. Found the line that popped off, reconnected with a zip tie, good to go.

Good luck!
2017 Fusion Sport
GFB DivValve/165* Thermo
K&N Panel/CFM Breather
Ult Perf Int Garrett Core/MKZ oil cooler
FMS 70mm TB/ NGK .026/LMS V6 93

Offline LipschitzWrath

  • Jr. Member
  • *
  • Thank You
  • -Given: 0
  • -Received: 6
  • Posts: 27
  • Ecobooster
  • Liked:
  • Likes Given: 0
Re: 2014 SHO Surging / Loss of Power
« Reply #16 on: July 30, 2022, 11:27:52 AM »


Id check all the vacc lines, especially involving boost.  It happened to me at the track one year no codes, no other symptoms just waaay down on trap speed. Found the line that popped off, reconnected with a zip tie, good to go.

Good luck!
DING DING DING! WE HAVE A WINNER!

Just popped the hood to check this and the exact hose connection in the video was off.

I haven't had a chance to test drive it yet but I'm confident that's it.

For now I reconnected the hose and zip tied it. Anyone know what size and type hose for that connection?

Sent from my SM-G973U using Tapatalk


Offline LipschitzWrath

  • Jr. Member
  • *
  • Thank You
  • -Given: 0
  • -Received: 6
  • Posts: 27
  • Ecobooster
  • Liked:
  • Likes Given: 0
Re: 2014 SHO Surging / Loss of Power
« Reply #17 on: August 02, 2022, 08:53:27 PM »
Alright, today was the first time I've driven to work since the issue was discovered. I'm happy to report the car is back to normal 100%. I'd consider this issue resolved unless something else comes up.

And for those following along, a new TCM resolved my wife's truck problems. Less than 5 minutes to fix. Too bad it cost me $750.

Sent from my SM-G973U using Tapatalk


 

* Recent Topics

Re: How to Use Whatever Rear Spring You Want
by 802SHO | Today at 09:28:15 AM
Hello, I have a 2013 Lincoln MKS EcoBoost I've been using as a tr...
Re: Explorer ST 11.69
by Macgyver | Today at 12:40:42 AM
Yeah I was just teasing. The smaller snails spool so fast and are a pe...
Re: Remote functions/remote start weak or intermittent
by polskifacet | September 25, 2022, 02:46:44 AM
I have found a workaround. Set key fob 1 as a mykey, dont use that key...
Re: Funny Taurus sighting......
by bpd1151 | September 10, 2022, 03:10:34 PM
LOL. So true. Interesting story.My Ex wife. Her Partner just transitio...
Re: HOW-TO: 3.5L EcoBoost AD Transmission Mounts
by FiveLeeter918 | September 07, 2022, 12:51:47 PM
You can also ask your tuner to increase your idle speed by 100 rpm whi...
The Elusive Camshafts
by Ta2dResqr | August 15, 2022, 09:28:36 AM
I sent a message to Kelford Cams late last week. They are based in NZ....
Re: Polyurethane bushings interest
by timbo | August 07, 2022, 11:03:32 AM
Well, as life happens, so do delays.  The week after I returned f...
18 ecoboost performance package transmission
by Chaliasif | August 03, 2022, 12:42:10 PM
have an ecoboost 18 PF with the digital meterWhenever i shift the gear...
Re: 2014 SHO Surging / Loss of Power
by LipschitzWrath | August 02, 2022, 08:53:27 PM
Alright, today was the first time I've driven to work since the i...
Sale Ends Today! $50 off SCT X4, BDX and Power Packages
by tmcphail | July 31, 2022, 10:32:13 AM
https://mcusercontent.com/0ca62e20c7302d91c702b3697/images/4d17c3ec-c4...

SimplePortal 2.3.5 © 2008-2012, SimplePortal