August 05, 2021, 09:09:16 AM
collapse
collapse

Author Topic:  All at once fueling issues  (Read 846 times)

Offline EvoSHO

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 1
  • Posts: 6
  • Ecobooster
  • Liked:
  • Likes Given: 3
All at once fueling issues
« on: June 04, 2021, 08:54:35 AM »
So 2013 SHO 91K miles, unleashed tune, 3 bar, intake, no cats DPs. 
Car had sudden misfire.  Dealer diagnosed fuel pressure sensor at rail.  Fixed and car drove fine for a month.  Then same miss and white smoke.  Checked the smoke and smelled strongly of fuel.  Went ahead and replaced fuel pressure sensor at tank, replaced ALL injectors with brand new units, new plugs, fresh oil change.

Car turned but no fire.  ONLY code showing is P00C6 that states:
If the high-pressure fuel system cannot achieve this threshold within a certain time and crankshaft rotation limits, the Powertrain Control Module (PCM) attempts to start the engine at fuel pump module pressure and sets the Diagnostic Trouble Code (DTC) P00C6.

Only thing I can think of the damn HPFP crapped itself.  I have ordered a new unit.

Any other possible insight?

Offline shoryde

  • Jr. Member
  • *
  • Cincinnati
  • Thank You
  • -Given: 11
  • -Received: 0
  • Posts: 17
  • Ecoboosted
  • Liked:
  • Likes Given: 1
Re: All at once fueling issues
« Reply #1 on: June 04, 2021, 11:05:30 AM »
Check all the plugs and connections from replacing the injectors. There are a lot of plugs up there that might not be fully seated 100%. I am running into a similar misfire only at WOT. Can you explain the misfire you are also seeing? Only in high RPM? Higher boost?


FYI, I am running DW 1700 injectors and was having Unleashed tune my system as well and he said it was not clear as to why I was getting misfires at wot. It looked ignition related. This weekend I am taking it 100% back to stock with a knock off set of injectors to see if they are the cause of my misfire. Apparently DW injectors have been an issue with some people.

Offline EvoSHO

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 1
  • Posts: 6
  • Ecobooster
  • Liked:
  • Likes Given: 3
Re: All at once fueling issues
« Reply #2 on: June 04, 2021, 11:43:56 AM »
Check all the plugs and connections from replacing the injectors. There are a lot of plugs up there that might not be fully seated 100%. I am running into a similar misfire only at WOT. Can you explain the misfire you are also seeing? Only in high RPM? Higher boost?


FYI, I am running DW 1700 injectors and was having Unleashed tune my system as well and he said it was not clear as to why I was getting misfires at wot. It looked ignition related. This weekend I am taking it 100% back to stock with a knock off set of injectors to see if they are the cause of my misfire. Apparently DW injectors have been an issue with some people.

Checked all connections across the board and even replaced fuel pump control module. 
My misfire was at low RPMs specifically at idle

Offline Macgyver

  • Super Moderator
  • Elite Member
  • *
  • *
  • Reading, Pa.......
  • Thank You
  • -Given: 100
  • -Received: 387
  • Posts: 974
  • Ecobooster
  • Liked:
  • Likes Given: 24
Re: All at once fueling issues
« Reply #3 on: June 04, 2021, 03:39:19 PM »
So 2013 SHO 91K miles, unleashed tune, 3 bar, intake, no cats DPs. 
Car had sudden misfire.  Dealer diagnosed fuel pressure sensor at rail.  Fixed and car drove fine for a month.  Then same miss and white smoke.  Checked the smoke and smelled strongly of fuel.  Went ahead and replaced fuel pressure sensor at tank, replaced ALL injectors with brand new units, new plugs, fresh oil change.

Car turned but no fire.  ONLY code showing is P00C6 that states:
If the high-pressure fuel system cannot achieve this threshold within a certain time and crankshaft rotation limits, the Powertrain Control Module (PCM) attempts to start the engine at fuel pump module pressure and sets the Diagnostic Trouble Code (DTC) P00C6.

Only thing I can think of the damn HPFP crapped itself.  I have ordered a new unit.

Any other possible insight?

Cheap part to throw at it would be the LPFP relay. It is behind the passenger rear seatback carpet fire wall area.

Offline EvoSHO

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 1
  • Posts: 6
  • Ecobooster
  • Liked:
  • Likes Given: 3
Re: All at once fueling issues
« Reply #4 on: June 04, 2021, 10:01:39 PM »
So 2013 SHO 91K miles, unleashed tune, 3 bar, intake, no cats DPs. 
Car had sudden misfire.  Dealer diagnosed fuel pressure sensor at rail.  Fixed and car drove fine for a month.  Then same miss and white smoke.  Checked the smoke and smelled strongly of fuel.  Went ahead and replaced fuel pressure sensor at tank, replaced ALL injectors with brand new units, new plugs, fresh oil change.

Car turned but no fire.  ONLY code showing is P00C6 that states:
If the high-pressure fuel system cannot achieve this threshold within a certain time and crankshaft rotation limits, the Powertrain Control Module (PCM) attempts to start the engine at fuel pump module pressure and sets the Diagnostic Trouble Code (DTC) P00C6.

Only thing I can think of the damn HPFP crapped itself.  I have ordered a new unit.

Any other possible insight?

Cheap part to throw at it would be the LPFP relay. It is behind the passenger rear seatback carpet fire wall area.

Yep did that as well

Offline shoryde

  • Jr. Member
  • *
  • Cincinnati
  • Thank You
  • -Given: 11
  • -Received: 0
  • Posts: 17
  • Ecoboosted
  • Liked:
  • Likes Given: 1
Re: All at once fueling issues
« Reply #5 on: June 04, 2021, 11:47:12 PM »
Fuses all good?

Offline EvoSHO

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Received: 1
  • Posts: 6
  • Ecobooster
  • Liked:
  • Likes Given: 3
Re: All at once fueling issues
« Reply #6 on: June 05, 2021, 07:05:14 PM »
Fuses all good?
Did not think to check that anything in particular I should be looking for?

 

* Recent Topics

Re: Any advice on how to improve 1/4 mile times?
by Blackhawk | August 04, 2021, 11:46:49 PM
This car should be running at least high 11s with all those mods. ...
Re: Terrain Management System Fault - wrench light
by TopherSho | August 03, 2021, 05:45:56 PM
Good notes to keep under the hat,  thanks for the share and updat...
2010 Taurus SHO, PCM issues
by withku | August 03, 2021, 01:41:48 PM
Hey all, my 2010 has been acting up lately. A while ago, my a/c stoppe...
Re: PTU 2017 3.5 EcoBoost Explorer 20 minute Fluid change all from underneath car
by SPDboat driver | August 02, 2021, 06:28:36 PM
Good video. You think you may lose some fluid through the vent if it h...
ecoboost_xsport Consolidated Build/Maintenance Thread
by Ecoboost_xsport | July 30, 2021, 08:24:58 PM
Even though I haven't been posting as frequently lately (YouTube ...
Re: 15 Interceptor Sedan Ecoboost with GHT Tune - Engine Coolant Overtemp
by SHOdded | July 30, 2021, 02:58:41 PM
on the 2.7, ford says to replace the ECT sensor and/or the knock senso...
Re: Random Pull/Torque Steer after new moog lower control arms.
by SHOdded | July 30, 2021, 02:54:07 PM
have an independent service shop verify your work with the LCAs. ...
Boost / Vacuum Source
by Ecoboost_xsport | July 29, 2021, 12:36:21 PM
Those of you wondering where a decent place to tap into a boost/vacuum...
Re: New from Minnesota...
by PDSHO | July 27, 2021, 04:15:43 PM
Greetings from Nebraska.Greg...
Re: Ol' Guy in New England........
by PDSHO | July 27, 2021, 04:13:04 PM
Greetings from Nebraska.Greg...

SimplePortal 2.3.5 © 2008-2012, SimplePortal