May 15, 2021, 04:03:25 AM
collapse

Author Topic:  2010 SHO EPAS / Rack & Pinion Noise  (Read 3492 times)

Offline guitar333

  • Newbie
  • *
  • Puerto Rico
  • Thank You
  • -Given: 8
  • -Received: 2
  • Posts: 9
  • Ecobooster
  • Liked:
  • Likes Given: 0
2010 SHO EPAS / Rack & Pinion Noise
« on: January 19, 2020, 12:06:13 PM »
Hey guys,

Lately my car has been making what sounds like a severe tire rubbing noise when turning either direction.
Got it on a lift yesterday and it's definitely the steering making the noise....
I'm hoping I don't have to replace the whole rack/pinion unit...but it seems likely.

Aside from the noise, it seems to steer fine and no alarms/codes. I doubt it but it sounds like something needs lubed or serviced, bad.
I did replace the whole suspension a few months ago, aside from the inner tie rods.

Any ideas? If it does indeed need replaced, I'm hoping to source the part online and have a local shop replace.
Best price I found was about $700 but seems it may need "programmed"? - hoping to not have to go through the dealer as I'm sure it's at least $2k :(

Thanks for any insight!

Here's a link to the sound:


2010 SHO - CAI, Downpipes, CR Rebuilt Turbos, LMS SIII Tune, H&R

1990 SHO - 3.2 Supercharged, all the modz

Offline 6500rpm

  • Quality Always Shoots Straight
  • Full Member
  • *
  • the safe zone just outside St Louis
  • Thank You
  • -Given: 51
  • -Received: 110
  • Posts: 135
  • Ecobooster
  • Liked:
  • Likes Given: 4
Re: 2010 SHO EPAS / Rack & Pinion Noise
« Reply #1 on: January 19, 2020, 12:24:31 PM »
Make sure the tie rod cover isn't dragging again something.
2013 SHO PP in Ruby Red Metallic, GTG Billet Grills, Duraflex Racer Chin Spoiler, DriveBright LED Driving/Turn Lights,160 T Stat, MSD Coils, All Royal Purple Lubricants, EPP Gen 2 Duel Intake and hotpipes,3 bar, Gearhead AO tuned!


Offline guitar333

  • Newbie
  • *
  • Puerto Rico
  • Thank You
  • -Given: 8
  • -Received: 2
  • Posts: 9
  • Ecobooster
  • Liked:
  • Likes Given: 0
Re: 2010 SHO EPAS / Rack & Pinion Noise
« Reply #2 on: January 19, 2020, 12:41:17 PM »
Thanks man. Good point. I didn't get a good look when it was on the lift but it sounds like something is rubbing.
You mean the inner tie rod boot right? I'll see if I can get it in the air again, may or may not be related but something in the front right is knocking too, even over the slightest bump. Sigh, I miss having a garage/jack/tools.


cayman gt4 0 60
2010 SHO - CAI, Downpipes, CR Rebuilt Turbos, LMS SIII Tune, H&R

1990 SHO - 3.2 Supercharged, all the modz

Offline 6500rpm

  • Quality Always Shoots Straight
  • Full Member
  • *
  • the safe zone just outside St Louis
  • Thank You
  • -Given: 51
  • -Received: 110
  • Posts: 135
  • Ecobooster
  • Liked:
  • Likes Given: 4
Re: 2010 SHO EPAS / Rack & Pinion Noise
« Reply #3 on: January 19, 2020, 01:57:28 PM »
Yup, one of the boots. On a lift the suspension geometry might change a little and the rub goes away, but if you look close you should see it. If it does it long enough it's going to wear a hole in the boot. It's the only thing I can think of that makes that sound, won't set a code, or change the feel of the steering.
2013 SHO PP in Ruby Red Metallic, GTG Billet Grills, Duraflex Racer Chin Spoiler, DriveBright LED Driving/Turn Lights,160 T Stat, MSD Coils, All Royal Purple Lubricants, EPP Gen 2 Duel Intake and hotpipes,3 bar, Gearhead AO tuned!


 


SimplePortal 2.3.5 © 2008-2012, SimplePortal