February 26, 2015, 05:25:06 PM
collapse
collapse

Author Topic: Search not giving any results?  (Read 632 times)

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 93
  • -Received: 641
  • Posts: 2624
    • EcoPowerParts
Search not giving any results?
« on: August 11, 2013, 07:11:26 PM »
For some reason the search box right above recent topics doesn't always give me results BUT the search link on the top of the forum does.
I'll work on that as soon as possible but in the mean time make sure to use this link:
http://www.ecoboostperformanceforum.com/index.php?action=search


Or the Search next to the help link on the top of the forum.

Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #1 on: August 14, 2013, 05:03:02 PM »
For some reason the search box right above recent topics doesn't always give me results BUT the search link on the top of the forum does.
I'll work on that as soon as possible but in the mean time make sure to use this link:
http://www.ecoboostperformanceforum.com/index.php?action=search


Or the Search next to the help link on the top of the forum.


the search box is contextual.

So, when you search when you are viewing a topic, it just searches that topic
when you search when you are viewing a board, it searches that board
when you search from the homepage it searches the whole site

what it needs is "search forum" changing to "search" or "search here" to make it more obvious what it means. thats a two second job.

(in an ideal world it would change contextually to "search this topic" "search this board" "search forum" depending on where you are.. but that will take some serious headscratching)

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 10
  • -Received: 49
  • Posts: 722
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #2 on: October 21, 2013, 05:53:16 AM »
Maybe I am to blame for doing something wrong, but I am finding the search function to be just about useless.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Online SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1482
  • -Received: 553
  • Posts: 4981
Re: Search not giving any results?
« Reply #3 on: October 21, 2013, 06:07:33 AM »
What issues are you having with it?  As stated in the previous post, search results depend on where you start the search from.  Please provide details so we can figure out how the issues can be addressed :)
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 10
  • -Received: 49
  • Posts: 722
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #4 on: October 21, 2013, 07:28:55 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 93
  • -Received: 641
  • Posts: 2624
    • EcoPowerParts
Re: Search not giving any results?
« Reply #5 on: October 21, 2013, 07:46:07 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
Nobody on here has, I was stating in general in the automotive world.
You'll also find that there has been other catastrophic failures by people on the board but they don't discuss it openly.
When I pop my motor or tranny I'll make sure I share what is broken and how I broke it. :)

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 10
  • -Received: 49
  • Posts: 722
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #6 on: October 21, 2013, 07:53:59 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
Nobody on here has, I was stating in general in the automotive world.
You'll also find that there has been other catastrophic failures by people on the board but they don't discuss it openly.
When I pop my motor or tranny I'll make sure I share what is broken and how I broke it. :)
This is what you wrote in the thread:
"Bob accidentally hydrolocked his motor with his meth injection. "
And when I search for "hydrolocked" is does not even find the above mentioned quote that was written in the last day.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 93
  • -Received: 641
  • Posts: 2624
    • EcoPowerParts
Re: Search not giving any results?
« Reply #7 on: October 21, 2013, 09:02:34 AM »
Click on forum then try again, I come up with both threads this one and the shift points one.
You must start at the root of the forum to search the global forum.

Online SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1482
  • -Received: 553
  • Posts: 4981
Re: Search not giving any results?
« Reply #8 on: October 21, 2013, 10:00:39 AM »
May be wrong, but I don't think Bob actually used the term "hydrolocked" when describing that event?  Hence the lack of search results.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 10
  • -Received: 49
  • Posts: 722
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #9 on: October 21, 2013, 10:16:40 AM »
May be wrong, but I don't think Bob actually used the term "hydrolocked" when describing that event?  Hence the lack of search results.
And that is exactly what happened. Lesson learned that words need to match letter for letter to yield results.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Online SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1482
  • -Received: 553
  • Posts: 4981
Re: Search not giving any results?
« Reply #10 on: October 21, 2013, 04:16:28 PM »
I don't know what it would take to take a dictionary based search engine to be implemented.  Doesn't seem like a small job, but there may be fuzzy logic variants out there that are small & efficient.  Possible development project?
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 93
  • -Received: 641
  • Posts: 2624
    • EcoPowerParts
Re: Search not giving any results?
« Reply #11 on: October 21, 2013, 04:26:38 PM »
They'd have to implement it in the core forumI'm definitely not trying to pay for that project.  You can use wildcards in that search function just fyi.

Sent from my SCH-I545 using Tapatalk


Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #12 on: November 22, 2013, 10:42:44 AM »
Searching for hydrolocked brings up two threads for me.

As i say its contextual, so to search whole forum search from forum page, to search a topic do it from topic page, to search a section do it from section page.

or use the full search by using the menu.

----

im not sure what you mean by dictionary based search?

php based search is very different to html based search.

On a html site, you put in a search term, and the site then scans every single html page looking for that search search term, and produces the results (results are cached to help with speed)

on a php based site such as this everything is stored in a database, so the search tool scans the database to then find the relevant topics. now obviously it doesnt scan the entire database. A large forum with say 500,000 posts, that would be 500,000 database entries it would have to scan. So instead, all the key words are pre stored in a single database table.

How accurate that search is depends on how big we specify the table to be. A small table, may only include a handful of keywords from each post, a larger table we may specify all words except connectives (and, if, of etc) to be stored. Or on a large table we may specify it store everything.

Of course the larger the table the more accurate the search.

Countered by, the larger the table the slower the search (and the slower the site as its doing extra php calls when users search).

Online SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1482
  • -Received: 553
  • Posts: 4981
Re: Search not giving any results?
« Reply #13 on: November 22, 2013, 11:12:56 PM »
Understood.  By dictionary based search, I was referring to allowing for synonyms or acronyms behind the scenes in the search along with what the user actually typed in.  The net is cast wider that way, and the user would get more results if available.  This could be an "optional" functionality, in that the user has to check a checkbox to activate it.

If I search for "EBPF", I could get results for both "EBPF" and "Ecoboost Performance Forum", for example, if I wanted.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light

Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #14 on: November 23, 2013, 04:39:06 PM »
ah, that would involve entirely rebuilding the way that search indexing is done.

 

Click button to donate to EBPF

Make a donation over $10 and get an EBPF sticker!

* Featured Topics

* Recent Topics

Playing with Dynolicious Fusion App
by BlackJac | Today at 05:23:10 PM
I figured I'd give Dynolicious Fusion a try. I did one run from 0...
Re: New LED light tubes/DRLs for your Taurus!
by Dxlnt1 | Today at 05:22:55 PM
I thought 2010-2012 SHO cars do NOT have DRL on cars. Will these still...
Re: Might be new to the Ecoboost crowd, help needed!
by Mors Mangone | Today at 05:22:08 PM
Thanks for all the input so far.  I'm actually going to loo...
Re: Avg BHP & WHP
by SHOnUup | Today at 05:08:49 PM
There's a driveline loss getting the power from crank to wheels o...
Re: Finally Tuned!!! But wait .. Snow
by Livernois Motorsports | Today at 04:41:02 PM
Well, I guess this needs to be discussed again.First and foremost, if ...
Re: "How-To" Replacing Blend Door Actuator Instructions
by Bosscav | Today at 04:23:42 PM
No worries on the cabin air filter. I did that in June when I got the ...
Issue with new LED bulbs
by Desoter_SHO | Today at 03:24:10 PM
Howdy folks!So I finally got off my butt and ordered up replacement LE...
Re: How to go about new performance tires?
by zamirlihari | Today at 02:54:07 PM
I personally have 255-45-20 and believe its about 1/2 inch wider and n...
Re: 0-85ish w/ Unleashed 92 octane tune!
by Bosscav | Today at 02:49:25 PM
Just add meth.  Answer to everything. lol.Now there's someth...
Re: 93 stage 4x or 4 plus
by zamirlihari | Today at 02:48:27 PM
It is an in-between tune for the client that has all of the bolt-ons s...
Re: x4 Can't Load Tune, Needs update
by SHOdded | Today at 01:09:37 PM
Great to hear!  Keep us updated on your adventures :)...
Re: WTS: LMS MyCAL Tuner 2011-2013 3.5/2.0 EcoBoost
by SHOdded | Today at 01:07:59 PM
Please update one of the pics with a postit or piece of paper with you...
Re: I want to De badge my lift gate
by TTSport15 | Today at 12:47:36 PM
Im out on the island but work in NYC......
Re: FS - K&N Cold Air Intake for Ford Taurus SHO/Lincoln MKS - $140 shipped
by TTSport15 | Today at 11:39:19 AM
great part great price glws!...
Re: 0 to 65ish pull
by IHeartGroceries | Today at 10:50:45 AM
Somebody post a 0-60+ pull in a stock SHO. I can't even remember ...

Back to top