July 27, 2015, 10:44:10 PM
collapse
collapse

Author Topic: Search not giving any results?  (Read 865 times)

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 92
  • -Received: 657
  • Posts: 2703
    • EcoPowerParts
Search not giving any results?
« on: August 11, 2013, 07:11:26 PM »
For some reason the search box right above recent topics doesn't always give me results BUT the search link on the top of the forum does.
I'll work on that as soon as possible but in the mean time make sure to use this link:
http://www.ecoboostperformanceforum.com/index.php?action=search


Or the Search next to the help link on the top of the forum.

Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #1 on: August 14, 2013, 05:03:02 PM »
For some reason the search box right above recent topics doesn't always give me results BUT the search link on the top of the forum does.
I'll work on that as soon as possible but in the mean time make sure to use this link:
http://www.ecoboostperformanceforum.com/index.php?action=search


Or the Search next to the help link on the top of the forum.


the search box is contextual.

So, when you search when you are viewing a topic, it just searches that topic
when you search when you are viewing a board, it searches that board
when you search from the homepage it searches the whole site

what it needs is "search forum" changing to "search" or "search here" to make it more obvious what it means. thats a two second job.

(in an ideal world it would change contextually to "search this topic" "search this board" "search forum" depending on where you are.. but that will take some serious headscratching)

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 8
  • -Received: 46
  • Posts: 729
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #2 on: October 21, 2013, 05:53:16 AM »
Maybe I am to blame for doing something wrong, but I am finding the search function to be just about useless.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1854
  • -Received: 684
  • Posts: 6282
Re: Search not giving any results?
« Reply #3 on: October 21, 2013, 06:07:33 AM »
What issues are you having with it?  As stated in the previous post, search results depend on where you start the search from.  Please provide details so we can figure out how the issues can be addressed :)
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 8
  • -Received: 46
  • Posts: 729
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #4 on: October 21, 2013, 07:28:55 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 92
  • -Received: 657
  • Posts: 2703
    • EcoPowerParts
Re: Search not giving any results?
« Reply #5 on: October 21, 2013, 07:46:07 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
Nobody on here has, I was stating in general in the automotive world.
You'll also find that there has been other catastrophic failures by people on the board but they don't discuss it openly.
When I pop my motor or tranny I'll make sure I share what is broken and how I broke it. :)

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 8
  • -Received: 46
  • Posts: 729
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #6 on: October 21, 2013, 07:53:59 AM »
I just read a post where someone mentioned their engine was hydrolocked, so I wanted to search for other issues pertaining to hydrolocked and the search came back with zero hits. This was using the seperate dedicated search page.
Nobody on here has, I was stating in general in the automotive world.
You'll also find that there has been other catastrophic failures by people on the board but they don't discuss it openly.
When I pop my motor or tranny I'll make sure I share what is broken and how I broke it. :)
This is what you wrote in the thread:
"Bob accidentally hydrolocked his motor with his meth injection. "
And when I search for "hydrolocked" is does not even find the above mentioned quote that was written in the last day.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 92
  • -Received: 657
  • Posts: 2703
    • EcoPowerParts
Re: Search not giving any results?
« Reply #7 on: October 21, 2013, 09:02:34 AM »
Click on forum then try again, I come up with both threads this one and the shift points one.
You must start at the root of the forum to search the global forum.

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1854
  • -Received: 684
  • Posts: 6282
Re: Search not giving any results?
« Reply #8 on: October 21, 2013, 10:00:39 AM »
May be wrong, but I don't think Bob actually used the term "hydrolocked" when describing that event?  Hence the lack of search results.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

Offline SRT82ECOBOOST

  • Elite Member
  • : Auburn, Maine
  • Thank You
  • -Given: 8
  • -Received: 46
  • Posts: 729
  • Must Go Faster!!!
Re: Search not giving any results?
« Reply #9 on: October 21, 2013, 10:16:40 AM »
May be wrong, but I don't think Bob actually used the term "hydrolocked" when describing that event?  Hence the lack of search results.
And that is exactly what happened. Lesson learned that words need to match letter for letter to yield results.
2013 SHO PP in White Platinum Metallic Tricoat, PPE Downpipes, Livernois Stage V8/3 Bar, Custom 2.5" Catback, 170 T-stat, Airaid CAI, H+R Springs and debadged
Boston Acoustics 2.1 Audio Upgrade

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1854
  • -Received: 684
  • Posts: 6282
Re: Search not giving any results?
« Reply #10 on: October 21, 2013, 04:16:28 PM »
I don't know what it would take to take a dictionary based search engine to be implemented.  Doesn't seem like a small job, but there may be fuzzy logic variants out there that are small & efficient.  Possible development project?
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

Offline EcoPowerParts

  • How can I help you today?
  • Elite Member
  • : Phoenix
  • Thank You
  • -Given: 92
  • -Received: 657
  • Posts: 2703
    • EcoPowerParts
Re: Search not giving any results?
« Reply #11 on: October 21, 2013, 04:26:38 PM »
They'd have to implement it in the core forumI'm definitely not trying to pay for that project.  You can use wildcards in that search function just fyi.

Sent from my SCH-I545 using Tapatalk


Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #12 on: November 22, 2013, 10:42:44 AM »
Searching for hydrolocked brings up two threads for me.

As i say its contextual, so to search whole forum search from forum page, to search a topic do it from topic page, to search a section do it from section page.

or use the full search by using the menu.

----

im not sure what you mean by dictionary based search?

php based search is very different to html based search.

On a html site, you put in a search term, and the site then scans every single html page looking for that search search term, and produces the results (results are cached to help with speed)

on a php based site such as this everything is stored in a database, so the search tool scans the database to then find the relevant topics. now obviously it doesnt scan the entire database. A large forum with say 500,000 posts, that would be 500,000 database entries it would have to scan. So instead, all the key words are pre stored in a single database table.

How accurate that search is depends on how big we specify the table to be. A small table, may only include a handful of keywords from each post, a larger table we may specify all words except connectives (and, if, of etc) to be stored. Or on a large table we may specify it store everything.

Of course the larger the table the more accurate the search.

Countered by, the larger the table the slower the search (and the slower the site as its doing extra php calls when users search).

Offline SHOdded

  • Administrator
  • Elite Member
  • : Beltsville, MD
  • Thank You
  • -Given: 1854
  • -Received: 684
  • Posts: 6282
Re: Search not giving any results?
« Reply #13 on: November 22, 2013, 11:12:56 PM »
Understood.  By dictionary based search, I was referring to allowing for synonyms or acronyms behind the scenes in the search along with what the user actually typed in.  The net is cast wider that way, and the user would get more results if available.  This could be an "optional" functionality, in that the user has to check a checkbox to activate it.

If I search for "EBPF", I could get results for both "EBPF" and "Ecoboost Performance Forum", for example, if I wanted.
2007 Ford Edge SEL, Powerstop F/R Brake Kit, TXT LED 6000K Lo & Hi Beams, W16W LED Reverse Bulbs, 3BSpec 2.5w Map Lights, 5W Cree rear dome lights, 5W Cree cargo light, DTBL LED Taillights

Offline dimspace

  • Administrator
  • Jr. Member
  • Thank You
  • -Given: 2
  • -Received: 17
  • Posts: 46
  • Ecobooster
    • Velorooms
Re: Search not giving any results?
« Reply #14 on: November 23, 2013, 04:39:06 PM »
ah, that would involve entirely rebuilding the way that search indexing is done.

 

Click button to donate to EBPF

Make a donation over $10 and get an EBPF sticker!

* Featured Topics

* Recent Topics

Re: 3.5 Ecoboost Carbon Buildup
by bpd1151 | Today at 09:35:31 PM
I enjoyed watching the engineers squirm a lil bit as well.But kudos to...
Re: installing exhaust today
by JagerBomb | Today at 08:26:36 PM
I know my bolts are tight for sure. I was chasing down the exhaust lea...
Re: LMS Downpipes Installed
by ElvenSho | Today at 08:05:44 PM
ohh ok, what was the reason for the revision... im having some weird A...
Re: Incorrect AFR at WOT Help!!
by kskrew4life | Today at 08:01:43 PM
i found two widgets one says "Drive cycle status since DTC clear&...
Re: Archoil
by f8tlSHO | Today at 06:08:47 PM
I didn't notice a difference in power or mpg, did not check temps...
Re: Front end creaking
by JagerBomb | Today at 04:14:37 PM
OEM only so far.  No pursuit of "performance" mounts li...
Re: Great Lakes Dragaway - new personal best 12.11@113
by BiGMaC | Today at 02:59:31 PM
Yea... 60' should have been 1.7-2.0 sec with a good launch....
Re: PTU fluid change on 13+ PP
by JagerBomb | Today at 01:27:29 PM
I might have to do this since I got an AWD warning light.  No ide...
Re: AWD warning light
by JagerBomb | Today at 01:22:45 PM
It could also be a sign that your PTU is n need of maintenance or repl...
Re: Wont start
by BiGMaC | Today at 12:42:57 PM
True... The dealer updated my ECM when they did my fuel pumps.  T...
Re: Random thoughts for the day
by SHOdded | Today at 12:35:44 PM
Anybody have a 2013 FSM (I assume 2010-12 is same, but JIC)?  Thi...
Re: LPFP and HPFP
by FoMoCoSHO | Today at 12:13:29 PM
As far as the LPFP, the only thing I've been able to find is duty...
Re: ---24th annual SHO Convention...SHO-CAGO---
by SHOnUup | Today at 08:24:34 AM
This is a couple videos of my 1st run around the road course at Blackh...
Re: 2016 Redesign?
by SHOnUup | Today at 05:01:00 AM
Here's what they had painted new colors and a generic sticker put...
Re: Looking to Trade... MKS or MKZ?
by PokerMunkee | July 26, 2015, 09:21:29 PM
Hell, even a 2013+ SHO would be a different car really.  If you w...

Back to top